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Datensatz 2009

salat09.sav

• um Wertelabels ergänzt

• um fehlende und unzulässige Werte bereinigt

• Daten der Dozenten ergänzt

• um Alter und BMI erweitert
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Daten Aggregieren

Daten > Aggregieren ...

• Ziel:

– Zusammenfassen von Beobachtungen
– wiederholte Beobachtungen
– Gruppenrepräsentant

• Break-Variable zur Unterteilung/Gruppierung

• Aggregierungsfunktionen:
Lage-/Streuungsmaße, prozentuale Anteile

• gruppenspezifische Fallzahlen

• Aggregieren in Kombination mit Zusammenfügen von Dateien zum
Umbau von Dateien
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Zusammenfügen von Dateien

Daten > Dateien zusammenfügen

• Fälle hinzufügen:
Variablen können in unterschiedlicher Reihenfolge vorliegen

• Variablen, die in beiden Dateien vorkommen, bleiben in der Arbeits-
datei unverändert

• bisherige Variablen sind mit (∗) gekennzeichnet,
hinzukommende Variablen mit (+)

• Verbinden anhand einer Schlüsselvariablen bei ungleicher Daten-
satzlänge oder bei Referenztabellen;

• Fälle beider Dateien müssen in aufsteigender Reihenfolge der
Schlüsselvariablen sortiert sein

• optionaler Herkunftsindikator: 0=Arbeitsdatei, 1=externe Datei
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Zusammenfügen von Dateien: Variablen hinzufügen

Fall 1: Beide Dateien haben gleiche Anzahl an Fällen und die gleichen
Fälle. Verwendung einer Schlüsselvariablen optional.

Fall 2: Externe Datei ist größer als Arbeitsdatei, es sollen aber nur Va-
riablen zu den Fällen der Arbeitsdatei hinzugefügt werden. Externe
Datei enthält zu verwendenden Schlüssel.

Fall 3: Externe Datei ist kleiner Arbeitsdatei, es interessieren nur Fälle
der externen Datei. Verwendeter Schlüssel ist in Arbeitsdatei.

Fall 4: In beiden Dateien kommen Beobachtungen vor; Vereinigungs-
menge bilden (teilweise fehlende Werte).
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Übung 5

1. Geben Sie unter Edit > Options ... > File Locations Ihren
persönlichen Ordner als standard Datenquelle an.

2. Fügen Sie die Umfrage 2009 salat09.sav zur Umfrage 2007
salat07 r.sav hinzu. Behalten Sie nur gemeinsam vorkommende
Variablen und ordnen Sie ggfs unterschiedliche Namen paarweise
an. Erzeugen Sie eine Variable mit dem Herkunftsjahr, vergeben
Sie entsprechende Wertelabels mit Hilfe des Dialogs Data > Define

Variable Properties.

3.(a) Ergänzen Sie fehlende Werte unter Nutzung von Transform >

Replace Missing Values .... Erzeugen Sie dazu eine neue Va-
riable, die fehlenden Werten den Mittelwert aller Beobachtungen
zuweist.

(b) Spezifizieren Sie den zugehörigen Variablentyp über Data >

Define Variable Properties.
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Übung 5

3.(c) Wiederholen Sie den Vorgang unter Beschränkung auf gleiches
Herkunftsjahr. Verwenden Sie dazu Transformieren > Fälle

auswählen.
(d) Vergleichen Sie die vorgeschlagenen Ersatzwerte. Welchen Effekt

hat die Fallauswahl auf das Ergebnis?
(e) Erzeugen Sie mit derselben Fallauswahl eine temporäre Datenma-

trix. Ermitteln Sie erneut die Ersatzwerte und vergleichen Sie.

4. Sortieren Sie nun die Daten der zusammengefügten Umfragen nach
Geschlecht und Salatkonsum und ordnen Sie die beiden Spalten ne-
beneinander an. Lässt sich eine Tendenz hinsichtlich des Salatvor-
liebe ablesen?

5. Teilen Sie die Stichprobe zu gleichen Teilen in Salatliebhaber und Sa-
latverweigerer ein. Verwenden Sie dazu die automatische Trennwer-
terstellung der visuellen Klassifizierung. Welche Option wählen Sie
für die Generierung der Cutpoints? Speichern Sie den Datensatz.
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Übung 5

6. Erzeugen Sie eine neue Datei, die die geschlechtsspezifischen Mit-
telwerte für Körpergröße und -gewicht enthält sowie den jeweiligen
Prozensatz jener mit mindestens 4-maligen Salatkonsum pro Woche.
Verwenden Sie die Aggregierungsfunktion.
Gilt für den Prozentsatz ’echt größer 4’ oder ’größer gleich 4’?
Leiten Sie eine Hypothese über das Ernährungsbewusstein unter
Geschlechtern ab.
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Datenexploration

• Analysieren > Deskriptive Statistiken > Häufigkeiten

erzeugt Statistiken, Graphiken und Häufigkeitstabelle

– Variable Geburtsdatum: Minimum, Maximum, Modalwert, Median
– Variable Salatkonsum: Balkendiagramm

• Analysieren > Deskriptive Statistiken > Deskriptive

liefert Statistiken und erzeugt ggfs standardisierte Variablen

• Analysieren > Deskriptive Statistiken > Explorative

Datenanalyse... liefert Statistiken und Graphiken (Boxplots), Tests
auf NV und vieles mehr
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Tests auf Verteilung

• Analysieren > Nichtparametrische Tests > Chi-Quadrat...

”H0: Daten folgen einer Gleichverteilung”
→ Erwartete Werte: Alle Kategorien gleich

• Analysieren > Nichtparametrische Tests > ...

... K-S bei einer Sichprobe

”H0: Daten folgen einer XX-Verteilung”, wobei XX für Normal-,
Gleich-, Poisson- und Exponentialverteilung stehen kann.

• Analysieren > Deskriptive Statistiken > ...

... Explorative Datenanalyse

testet mit Kolmogorov-Smirnow oder Shapiro-Wilks auf NV

• Analysieren > Deskriptive Statistiken > Häufigkeiten...

– Diagramme: Histogramme mit Normalverteilungskurve
– ±σ entspricht den Wendepunkten in der Dichte
– NV (0, 1) : x̄ ± {1/2/3}σ̂ entspricht {68.26/95.44/99.72}%
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Übung 6

1. Laden Sie die Datendatei Eier oKat.sav, die für 1000 Hühnereier
der Hühnerrasse ”Loheimer Braun” verschiedene Kennzeichen
enthält.

2. Beschreiben Sie den Datensatz, indem Sie jede Variable geeignet vi-
sualisieren und sinnvolle Statistiken berechnen. Sind die metrischen
Variablen normal-verteilt? Wie lässt sich dies bereits an Schiefe und
Wölbung ablesen? Welche graphischen Darstellungen können Sie
zur Überprüfung auf NV generieren? Lassen sich Ausreißerwerte
identifizieren?

3. Erstellen Sie einen neuen Datensatz Eier Fallausschluss.sav,
der die Daten für braunfarbige Eier enthält, die schwerer als 48 g
und leichter als 77 g sind mit einer Breite > 41 mm und < 47 mm und
einer Höhe > 49 mm und < 63 mm.
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Übung 6

4. Erweitern Sie den reduzierten Datensatz um die Information der
Hühnerhaltung (Eier Haltung.sav). Inspizieren Sie die Daten vor-
her und bringen Sie sie in die benötigte Reihenfolge.

5. Kategorisieren Sie die Höhe eines Hühnereis in ’klein’ (kleiner
50 mm), ’mittel’ und ’groß’ (mindestens 60 mm) durch (a) Umkodie-
rung in eine andere Variable und (b) visuelles Klassieren. Verglei-
chen Sie die Ergebnisse rechnerisch.

6. Geben Sie das durchschnittliche Gewicht für nach Haltungsart und
Höhenkategorie gruppierte Daten an, zunächst durch Aggregieren.
Fügen Sie dann diejenigen Werte ein, die Sie über Analysieren >

Mittelwerte... erhalten und vergleichen Sie.
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Übung 6

7. Klassieren Sie die Variable Gewicht in eine neue Variable in
(möglichst) gleichmäßig besetzte Kategorien ’leicht’, ’mittel’ und
’schwer’. Überprüfen Sie die angestrebte Gleichverteilung graphisch
und per Test. Warum sind die Daten nicht exakt gleichverteilt?

8. Prüfen Sie die metrischen Variablen auf Normalverteilung. Verwen-
den Sie Ihnen dabei bekannte graphische Verfahren und Tests.

9. Speichern Sie den Datensatz als Eier Uebung6.sav.
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Kreuztabelle – CROSSTABS

Analysieren > Deskriptive Statistiken > Kreuztabelle

• Statistiken: z. B. χ2-Unabhängigkeitstest, Kontingenzkoeffizient bei
Nominalniveau

• Zellen: z. B. beobachtete/erwartete Häufigkeiten, zeilenweise Pro-
zente

• Gruppiertes Balkendiagramm generierbar

• Beispiel: Haltung– versus Gewichtskategorien

• Pivot–Tabelle
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Viewer: Pivot–Tabelle

• klare, schlüssige und aussagekräftige Präsentation der Ergebnisse

• kategoriale Variablen definieren Aufbau (Zeilen/Spalten/Schichten)

• häufig auch Strukturierung durch berechnete Zellenstatistiken
(Mittelwert, Median, #Beobachtete, #Erwartete, Prozente etc.)

• geschachtelte versus gestapelte Tabellen

• spezifischen SPSS Pivot Table Editor öffnen:

– Doppelklick auf Tabelle
– Tabelle im Viewer auswählen und über Menüleiste
Edit > Edit Content > In Separate Window

• Format > TableLooks

Tabellenvorlagen zur schnellen Layoutänderung z. B. zum akademi-
schen Stil
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Viewer: Pivot–Tabelle

• Edit > Toolbar zur Modifikation von Schriftart/-größe

• Pivot > Pivoting Trays Drag & Drop zum Umsortieren der Varia-
blen in Zeilen, Spalten und Schichten

• Reihenfolge der Icons im Pivoting Trays Fenster repräsentiert Rei-
henfolge in der Tabelle

• schneller Schichtwechsel über Pfeile des Pivot-Symbols

• Crtl + Alt + Klick auf Kategorielabel (z.B. ’weiblich’), View >

Hide um einzelne Kategorien auszublenden

• Label markieren, Bearbeiten > Auswählen > Datenzellen und
Format > Zelleneigenschaften:
Horizontale/vertikale Ausrichtung, Schattierung, Werteformat

• Umwandlung in interaktive Graphik möglich
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Übung 7: Kontingenztafel

• Öffnen Sie den in Übung 5 abgespeicherten Datensatz.

• Erstellen Sie eine Kontingenztafel für Geschlecht versus Salatliebhaber/-
verweigerer und schichten Sie diese gemäß Herkunftsjahr. Nehmen
Sie neben den beobachteten und erwarteten Werten auch die zeilen-
weise Prozente in die Tafel auf.

• Explorieren Sie die Darstellungsweisen durch Pivoting. Blenden Sie
die erwarteten Werte aus.

• Gibt es einen signifikanten Zusammenhang im Jahr 2007 oder 2009?
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Kontingenztafel mit Sekundärdaten

• direkte Eingabe der Sekundärdaten:

– dichotome Variablen Gruppe und Befund
– Variable mit Gewichten der Kontingenztafelfelder

• Daten > Fälle gewichten (Kontrollfeld links unten)

• Analysieren > Deskriptive Statistiken > Kreuztabellen...

• Faustregel von mindestens 5 Fällen pro Zelle ”verletzt”
→ exakter Test nach Fisher
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Übung 8: Klinische Studie

Diagnose: temporaler Arteriitis (TA) mit und ohne neuroophthalmologi-
schen Komplikationen (NOC)

Methode: Dopplersonographie der periorbitalen Arterien (DSPA) liefert
in der Gruppe der Patienten mit TA und mit NOC 10 pathologische
und 15 unauffällige Befunde und bei Patienten mit TA ohne NOC 5
pathologische und 57 unauffällige Befunde.

Frage: Weisen Patienten mit zusätzlichen NOC eher Schädigungen
der PA auf als Patienten ohne NOC?
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Korrelationsanalyse
Analysieren > Korrelation > Bivariat...

• eine Korrelationsmatrix für alle metrischen Variablen

• parametrisch: Produkt–Moment–Korrelation nach Bravais & Pearson
– misst linearen Zusammenhang
– NV–Annahme

ρ =
Cov(x, y)

sxsy

d. h. für ρ = 0 könnte immer noch ein anderer als linearer Zusam-
menhang bestehen und für ρ → 1 könnte zusätzlich ein anderer Zu-
sammenhang bestehen.

• nicht–parametrisch: Korrelation nach Spearman
– misst monotonen Zusammenhang

• Pivot: Umstrukturierung in reine Korrelationsmatrix
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Korrelationsanalyse

Analysieren > Korrelation > Partiell...

• nur parametrische Variante verfügbar (NV–Annahme!)

• Kontrollvariable, um deren Einfluss der Zusammenhang zweier an-
derer Merkmale bereinigt wird

• Beispiel: ”Breite und Höhe gleichgewichtiger Eier sind (partiell linear)
negativ korreliert” , d. h. ”H0 : ρBreite∗Hoehe|Gewicht ≥ 0”
→ einseitige Testung
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Übung 9: Korrelationsanalyse

1. Führen Sie eine Korrelationsanalyse der metrischen Variablen in
Eier Uebung6.sav durch. Erstellen Sie ein Streudiagramm Gewicht
versus Breite. Lässt sich eine Gerade, die den linearen funktionalen
Zusammenhang zweier Merkmale widerspiegelt, hinzufügen? Sind
Gewicht und Breite von einander unabhängig? Welcher Zusammen-
hang besteht zwischen Bestimmtheitsmaß und Korrelationskoeffizi-
ent?

2. Generieren Sie eine Streudiagrammmatrix für Gewicht, Breite und
Höhe. Fügen Sie Regressionslinien hinzu. Ist der Zshang zwischen
Breite und Höhe plausible?

3. Generieren Sie ein gemäß Gewichtskategorie eingefärbtes Streudia-
gramm für Breite versus Höhe. Wie beurteilen Sie jetzt die gruppen-
spezifische Korrelation?

4. Überprüfen Sie sodann anhand der Betrachtung partieller Korrelatio-
nen, ob sich Breite und Höhe eines Hühnereis umgekehrt proportio-
nal zueinander verhalten.


